DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

Problem uploading to board - bad nanos???

  • DXmoocow Monday, September 10, 2012 7:34 AM Reply
    I bought these nanos in the past and had no problems, and currently have no problems using my other arduinos (including the earlier nano), but the two I received today are not communicating with the interface, regardless of board/serial port/programmer settings (message says "Problem uploading to board...avrdude stk500_recv(): programmer not responding") This is happening on 3 different computers. The simple blink sketch won't take. Am I doing something wrong or is this a bad batch of nanos?

    Edit: when I press the reset button the built in leds (pin 13) don't blink so I'm guessing they haven't had the bootloader burned on, or something along those lines. Also, when I try uploading using the verbose method (as suggested on the arduino/en/troubleshooting page) I get the same message as before, if that helps. Any help would be appreciated.
    Posts(119) | Reviews | Tip post

    post edited by DXmoocow on 9/10/2012 at 7:51 AM
  • DXmoocow Saturday, September 15, 2012 7:38 AM Reply
    As I suspected, it seems this batch of nanos never got the bootloader burned onto them so they are pretty useless unless you have a programmer and are willing to solder on some pins/wires to the ICSP connections. If you have these and want to try, see the arduino page at http://arduino.cc/en/Hacking/Programmer for how to go about it.
    If you don't know what the bootloader is, it is basically an arduinos equivalent to an operating system on your computer - it decides how to run the code and the hardware.
    I am currently trying to RMA these and will let you know the outcome when DX customer service sorts it out. At the moment they are having trouble understanding what is wrong with the boards and don't quite no how to respond - Hopefully my last explanation was plain enough for them.
    I will write again as oon as it is sorted out.
    Posts(119) | Reviews | Tip post

    post edited by DXmoocow on 9/18/2012 at 5:06 AM
  • DXmoocow Tuesday, September 18, 2012 5:08 AM Reply
    DX are now aware of the problem and have agreed to RMA at their expense - thankyou to DX.
    I assume they will sort it out shortly. Might pay to check with them first about this problem or try one af the other nanos on DX (and their seems to be a few) if you are buying sometime close to the time of this posting though.
    Posts(119) | Reviews | Tip post

  • emertonom Sunday, September 23, 2012 10:35 AM Reply
    I'm having the same problem. Thanks for figuring out the cause! I'm going to contact them for an RMA.
    Posts(8) | Reviews | Tip post

  • emertonom Sunday, September 23, 2012 12:03 PM Reply
    Ah! I found a solution that didn't require RMA'ing, using a second Arduino Uno as an ISP programmer.

    If anyone has another, working arduino, and wants to do this, there are instructions on this page: http://www.sparkfun.com/tutorials/247

    The only tricky part was figuring out which pins to connect on the Nano. The reference for that is here: http://arduino.cc/en/uploads/Main/ArduinoNano30Schematic.pdf

    In particular, the mapping from the "arduino to be programmed" column (under "hooking up your board" on the sparkfun page) to the nano board is as follows:
    "Vcc/pin2" is actually the pin labelled "Vin."
    "Gnd/pin6" is actually the pin labelled "Gnd" which is right next to "Vin."
    "MOSI/pin4" indicates the pin labelled "D11."
    "MISO/pin1" indicates the pin labelled "D12."
    "SCK/pin3" indicates the pin labelled "D13."
    (I know these last three are what are listed under "working arduino," but when I hooked it up this way, it did program correctly--it's an odd coincidence that the pins they chose as outputs for the ArduinoISP program happen also to be the corresponding pins on the Nano. Or perhaps they did that intentionally, so that you can program a second Nano from a first nano by hooking them up almost pin-for-pin. Either way, it's what works.)
    "Reset/pin5" indicates the "RST" pin next to the "Gnd" and "Vin" pins.

    I didn't have to use the 110ohm resistor (or three 330ohm resistors) to disable the auto-reset as mentioned on the linked page "a note of caution about ArduinoISP" (http://laclefyoshi.blogspot.com/2011/01/note-of-caution-for-arduino-isp.html )--I'm not sure why. But it appears to have worked (my test sketch is running happily), so I'm not too concerned. The "error" LED did flash a couple times during programming, and a red light started blinking on the nano after I'd burnt the bootloader, but it stopped once I'd uploaded a test sketch.

    I'm very pleased with this! Hope this helps someone else who has this problem.
    --Nick
    Posts(8) | Reviews | Tip post(10)

  • DXmoocow Monday, September 24, 2012 6:36 AM Reply
    Congratulations Enertonom - but it does sound like a lot of effort to fix a problem that shouldn't have existed in the first place. I did mange to send mine back to DX office in my country (Australia) after DX promised
    "We will arrange for the replacement of the product and reimbursement for the return postage after the package is received and processed. DealExtreme will cover the actual postage according to the shipping receipt you provide. "

    However, I have just had a response from customer service saying they can refund the purchase price but only offer store credit for the postage! Hmmmm....thats not how I interpreted their previous statement, so I was a little unhappy with this. However, at least they have come to the party and made some sort of amends. (Now waiting for the refund and instructions on how to use store credit, which I hope is relatively straight forward!)

    To anyone else having these problems their is also another option that is relatively cheap way to make a parrallel programmer - see http://arduino.cc/en/Hacking/ParallelProgrammer, but you will need to purchase/scavenge a few parts and solder some pins to the ICSP connection pads on the nano.
    So, in summary, your 3 known options to addres this problem are:
    *RMA
    *The sparkfun method (http://www.sparkfun.com/tutorials/247)
    *the (possibly simpler) Arduino IDE method with a parrallel programmer (http://arduino.cc/en/Hacking/ParallelProgrammer and instructions here at http://arduino.cc/en/Hacking/Bootloader
    Posts(119) | Reviews | Tip post

    post edited by DXmoocow on 9/24/2012 at 6:39 AM
  • vaahtera Sunday, September 30, 2012 10:01 AM Reply
    Thanks emertonom!
    I spent like 2-3 hours today trying to figure out if I have two defective Nanos at my desk. After I found out your post it was a matter of minutes before I got both working. With older Nano from DX =) Sent you couple of DX points with "Tip post", hope you find some use to them.

    Of course it is not ideal to have to fix your brand new stuff like DXmoocow said but way less trouble and more importantly time wasted RMAing.
    Posts(45) | Reviews | Tip post

  • DXmoocow Monday, October 01, 2012 5:59 AM Reply
    Yeah - it was pretty painful going through the RMA process and it did waste a lot of time. If I had the parts I would have just fixed mine myself as well, (but partly didn't want to do that on principle).
    I did get my refund for the product but not for the postage, (which I got as 'store credit' instead). Anyway, I hope not too many others have this problem before the manufacturer fixes it. As I previously stated, if you are thinking about ordering these I would enquire with DX first to see if they have had a discussion with the manufacturer, otherwise go for one of the other nanos on this site.
    Posts(119) | Reviews | Tip post

  • Magsonlz Thursday, October 04, 2012 9:16 AM Reply
    I just received the nano and it did not come with the bootloader.
    Fortunately I had a UNO on hands and used the procedure from emertonom and it worked just perfect. I did not connect the resistors as well and I did not get any "error" during the bootloader burn. The red LED in the nano blinked after uploading the bootloader as I believe the blink sketch comes together.
    Thanks for sharing the information!

    Posts(1) | Reviews | Tip post

  • emertonom Thursday, October 04, 2012 1:34 PM Reply
    Yeah, it occurred to me that it might have uploaded the "blink" sketch as a test, but I wasn't sure. As for the error light, that did blink a couple of times on mine, but only *really* briefly, and it's just as likely I'd accidentally pushed something around on the breadboard.

    I'm glad people are finding this useful! I completely agree with DXmoocow that this problem shouldn't have existed in the first place--it's troubling that DealExtreme hasn't fixed this problem yet (almost a month later), and I hope this post isn't preventing them from catching on to it. But it was a big relief to be able to fix it without RMA'ing, since the shipments are kind of slow, and I hoped other arduino fans (who might have an extra board around for experimenting) could benefit from that.

    And thanks for the tip, vaahtera! I'm new here, so I don't really know how that works, but I appreciate the gesture. :)
    Posts(8) | Reviews | Tip post

Page 1 of 2
Go to Page:
«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere