Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

My experience after 1 month of use

  • ThinkPad Thursday, March 4, 2010 1:56 PM Reply
    I also have this charger, received my TrustFire 2500mAh yesterday, put them in this charger after using with my flashlight, but after an hour of charging, the charger went bad.

    When i connect power without any batteries in it, the light is steady on, normally it would be flashing to indicate that no batteries were inserted.

    It is also smelling like burnt electronics (wasn't smelling before this 'accident' )

    I am going to make a ticket, and we will see what happens.
    Posts(116) | Reviews | Tip post

  • Shriker Tuesday, March 30, 2010 4:06 PM Reply
    The trick for 240v supplies is to use a standard Nokia phone charger instead that has been made for 240v. I also have a power supply for my usb hub/flash card reader that does the trick too. Thats why i got this charger in the first place actually since i dont think any of them really support 240v even if they claim to.
    Posts(37) | Reviews | Tip post

  • _Diceman Wednesday, April 28, 2010 12:54 AM Reply
    The Trustfire charger also has this problem, as China is a 220-240V country I find it weird that they build their electronics to work with 110-120V only. Must be the fact that they export so much to the USA and just get the cheapest components available.

    Posts(481) | Reviews | Tip post

Page 2 of 2
Go to Page:
«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere