Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

No Longer Works - Blue LED flashes constantly

  • melvinfox Monday, October 31, 2011 9:11 AM Reply
    The 8 Gb and the 4 Gb cards are Kingston 6 class. The problem is appear basically in the outside shooting. When i am shooting home thats problem almost dont appear.
    Posts(51) | Reviews | Tip post

  • gr33ndragon Wednesday, November 9, 2011 2:32 AM Reply
    oke so i have got my second pair cause the first didnt work, what it does is bleu is flashing and after 1 min it wil shutdown(same as the first one) in the manuel it means "WRONG OPERATIONS" reset
    reset does not help !!!!

    ANYONE KNOWS HOW TO SOLVE THIS ???????
    Posts(1) | Reviews | Tip post

  • MVG0673 Saturday, February 4, 2012 6:14 PM Reply
    Tried again... this time with a 8 GB Class 10 card formatted fat32. Same results! As soon as I press the power button, it thinks a for a few seconds then the blue light flashes twice real quick then just flashes about once a second and the unit is unresponsive until I reset it. Very frustrating!!
    Posts(8) | Reviews | Tip post

  • MVG0673 Saturday, February 4, 2012 6:15 PM Reply
    Tried again... this time with a 8 GB Class 10 card formatted fat32. Same results! As soon as I press the power button, it thinks a for a few seconds then the blue light flashes twice real quick then just flashes about once a second and the unit is unresponsive until I reset it. Very frustrating!!
    Posts(8) | Reviews | Tip post

  • Jordanfoto Tuesday, May 29, 2012 12:53 PM Reply
    Old thread I know, but I found the problem taking these apart for anybody that has this comes across this. On the side where the operation buttons are, there are two screws. Remove these, then take off the back piece cover. The memory card board connects to the main pc board, press down on the memory card board to make sure it is connected completely. The flashing blue light problem is because the memory card reader isn't being read by the camera. It is not the best design and could come loose wearing these. I put some tape inside to help it stay connected better.
    Posts(8) | Reviews | Tip post

  • MVG0673 Tuesday, May 29, 2012 9:18 PM Reply
    Thanks for the info Jordanfoto. What type of memory card are you using?
    I actually took my set a part already to take a look. Everything seemed in order from what I could tell. I did it apart again briefly after reading your post. Again, nothing out of the ordinary. I took the two screws off to remove the back cover and expose the memory card reader. From there I removed the screw holding the reader to the rest of the unit. I reseated that connection and tried powering it up a few times with out any further luck.
    Posts(8) | Reviews | Tip post

  • Jordanfoto Tuesday, May 29, 2012 10:41 PM Reply
    I used patriot class 10 16gb, samsung 8gb class 10, kingston class 4 etc. All work fine with the camera but the class 4 has corrupted frames. One time when it had the same flashing blue led problem and the reseating of the card reader didn't work, I put that part in the wash and dryer with some clothes and plugged it back in and the camera has worked since then. So maybe dirt gets inside the reader easily. I still have to press the reset button every now and then when it won't connect to the computer or record.
    Also the processor chip sits right on top of the card reader so possible it is getting too hot and desoldering the connections so you might want to hold a lighter to the board for a few seconds and that might get it working again. If that doesn't work yours is most likely dead.
    Posts(8) | Reviews | Tip post

  • mclaingZulu Wednesday, May 30, 2012 12:14 AM Reply
    Thanks for the posts. I have noticed on mine that the ribbon cable to the camera has now got the thinnest crack across 3 lines. It is where the glasses fold up, and I can only confirm the break by looking at it under a microscope. Until then, the glasses worked so well for me - I sure got allot of use from them - I still haven't found a camera that is as HD as these. Does anyone have any ideas on how to repair the orange ribbon cable with copper tracks, successfully, because my glasses just flash the blue light too now. I haven't had any luck finding that replacement part, but if your glasses still operate, don't open and close them too often.
    Posts(7) | Reviews | Tip post

  • Jordanfoto Thursday, May 31, 2012 12:01 AM Reply
    If the ribbon breaks the glasses are trash because the ribbon goes right into the ccd imager. They really should use a metal shield or metal braided cable. It would be much cheaper to buy a replacement pair. These aren't available on dealextreme now and I contacted them and they said won't be getting any more in stock. Save the battery as those are hard to find.
    Posts(8) | Reviews | Tip post

Page 2 of 2
Go to Page:
«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere