Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

Firmware

  • xxxQ2 Thursday, October 03, 2013 8:17 PM Reply
    Thanks for the links. In my experience, most recent FW updates are usually on http://www.tv2211.com/TechDown.asp

    1. Agreed. Had to update as video playback used to hang from time to time. Also, it's recommended to have the current firmware on hand to be able to rollback to it if anything goes wrong with the new version (new bugs, worse performance, etc).

    2. I don't think there is a JA2004 model - there are no such model names on FW download pages. You most probably have JA7204. For JA7204, there were a lot of versions. The oldest I've seen is 1.2.0, current is 1.8.3. I don't think the letter "S" in the model name indicates SATA support as I have both JA7204 and JA7204S, and both support SATA.

    4. They are quite selective indeed! Almost bricked mine because of this.

    5. help.rom is completely identical to the firmware files, the only difference is name. So you can just rename whatever firmware you have to "help.rom" and use it to fix your DVR.

    6. Could you please provide the links to this forums? I'd like to try to connect to DVR via Telnet. Any additional information and links would also be appreciated.

    My JA7204S came with 1.6.13 6932B13 firmware and worked well. Updated to 1.8.3 - so far so good.

    Why do you think you need FWHI1504S_* firmware? If you have JA7204 (older version of the DVR in the picture above) - than you need FWHI1504A_* firmware (I have a couple of versions and can share them if needed, but the latest version should work as well). If you have JA7204S (current version of this DVR, SKU 151451) - than you need FWHI1504S_* firmware (the latest version works fine).

    Latest JA7204: http://www.tv2211.com/UploadFile/Project2/20130827174820717.rar
    Latest JA7204S: http://www.tv2211.com/UploadFile/Project2/20130827165140459.rar
    Posts(22) | Reviews | Tip post

  • romantu Friday, October 04, 2013 3:23 AM Reply
    The differences between the JA7204 and the JA2004 models are illustrated here:
    -- http://www.tv2211.com/en/Product.asp?ClassID=98
    and here:
    -- http://www.juancctv.com/category/4-channel-dvrs.html
    I found even one JA3004 model here:
    -- http://anxinwei.net/goods.php?id=673
    The optical differences are in the design and especially the interface between the grey and the black half of the front panel. My DVR looks like this one:
    http://www.juancctv.com/product/4ch-d1-h-264-dvr-for-r-2004c.html
    It also originally said in the menu "Device Model: JA7204S" and came originally with the JA7204S_1_6_1_6932B1. It looks very similar to the SKU 151451, just optically different is the design of the black section on the front left corner. Later I noticed a white sticker at the back saying s/n: JA2004000069065.
    In the beginning I believed the System Info so I decided to go for the latest F/W 1.8.3. for JA7204S: FWHI1504S_20130821_DVR_JA7204S_1_8_3_7969B10.rom.
    After successful update from 1.6.1 to 1.8.3 the screen looked fine, divided in 4, just all the buttons on the front panel were displaced (some of them were not working at all). Thanks God with the mouse there was no problem to go through the menu and adjust any settings and perform new F/W update.
    Then I downgraded to 1.8.2 with the JA7204S_1_8_2_7969 but the buttons were still displaced. Then I found on the juancctv.com the firmware "2004 new firmware 6932B13" with the JA7204S_1_6_13_6932B13.rom and my DVR said loading error and rejected the firmware. It was nevertheless possible to revert back to 1_8_3 but after a re-boot I got stuck in the welcoming screen. The files that begin with FWHI1504A instead of FWHI1504S were not recognized by my DVR at all.

    After all said, I think that my drive is really one from the 2004 series and I believe that the F/W versions are not compatible to the 7204 series. My DVR is currently still bricked. That is why I would appreciate if you could share any F/W that begins with FWHI1504S and has a version between 1.6.1 and 1.6.12. The latest 1.6.13 did not work for me at the time my drive was operational.

    In this thread they speak about another make and model, but the approach in interesting. They share 4 .bin files like AppImg_4.bin, fboot_4.bin, kernel_4.bin, xml_4.bin (opposed to our .rom files). I think these are the source files for the operating system, whereas our .rom files are some kind of compressed.
    http://www.cctvforum.com/viewtopic.php?f=3&t=27073 (this is just for info, it will probably not work on our JUAN DVRs)

    In this thread they succeeded using telnet connection and a duplicate (properly working) drive:
    http://www.cctvforum.com/viewtopic.php?f=3&t=30326

    Do you know if after F/W update failure we need to shorten any chip resistor pins on 7204 or 2004 or the rescue procedure (load F/W directly from USB instead of Chip) works also directly without any manual intervention? What makes the DVR actually load and initialize from the USB first instead of loading the corrupted version from the Chip?

    For anybody interested:
    I can provide the following F/W whenever needed:
    FWHI1504A_20120719_DVR_JA7204_1_6_3_6932B3.rom
    FWHI1504A_20130112_DVR_JA7204_1_6_13_6932B13.rom
    FWHI1504S_20130112_DVR_JA7204S_1_6_13_6932B13.rom
    FWHI1504S_20130619_DVR_JA7204S_1_8_2_7969.rom
    FWHI1504A_20130821_DVR_JA7204_1_8_3_7969B10.rom
    FWHI1504S_20130821_DVR_JA7204S_1_8_3_7969B10
    FWHI2104_20130821_DVR_JA7204D_1_8_3_7969B10.rom
    please check if they are not available on the manufacturer's sites first. Links are available two posts above in this thread. Hint: try also using the Chinese language version of the sites, as the English version may contain less files in the Download section.

    I am looking for:
    FWHI1504S_2012????_DVR_JA7204S_1_6_1_6932B1
    or any other F/W up to 1.6.12 that begins with FWHI1504S
    Thanks
    Posts(3) | Reviews | Tip post

  • xxxQ2 Monday, October 07, 2013 8:51 PM Reply
    Where did you get the DVR from? Is it from DX?

    I got my from DX, sku 151451. The model name is "JA7204S" (from Version Info menu), and it came with 1.6.13 6932B13 firmware.
    It also has a white label at the back saying "S/N:JA2004xxxxxxxxxxxx".

    So my guess would be that JA2004 is just the hardware platform name (DVR internals). If you look here: http://http://www.tv2211.com/TechDown.asp, there will be no mentions of JA2004.
    It is most likely that you have JA7204S model as it was written in the menu originally.

    "In the beginning I believed the System Info so I decided to go for the latest F/W 1.8.3. for JA7204S: FWHI1504S_20130821_DVR_JA7204S_1_8_3_7969B10.rom"
    My DVR is currently running this version.

    "After successful update from 1.6.1 to 1.8.3 the screen looked fine, divided in 4, just all the buttons on the front panel were displaced (some of them were not working at all)."
    In the recent versions a new setting called "KeyPad Type" has been introduced to the "General setup" menu. It looks like it can be used to change the mapping of the buttons on the front panel.
    Probably it is there so that the manufacturer could produce one build of the firmware for the multiple device models, with different front panels (e.g. having additional buttons).
    In my case I did not have to change this setting after the update to 1.8.3 as everything worked fine. The default setting was "Standard". When I changed it to "16" - nothing changed and all buttons still worked fine. With other values (18 and 23) - I got the exact picture you have described, i.e. buttons' mapping was wrong.
    Most probably you just had to choose the correct value for this new setting (it should be "16", as your model has 16 buttons) after the update to 1.8.3.

    Regarding the firmware.
    Our firmware (*.rom files) consists of several main parts:
    1. Header (various meta information, descriptors for other parts of FW)
    2. Linux Kernel
    3. Linux file system (squashfs format)
    4. Resources package: images, UI, web interface (tar.gz format for the earlier versions, squashfs format for latest version).

    Unfortunately I don't have any FWHI1504S_* firmware except for the latest version (1.8.3), however I'm positive that your DVR should work with it just fine after changing the "KeyPad Type" setting.

    How much your DVR is bricked exactly? When I bricked mine, it just kept rebooting again and again with a couple of beeps in between - in this case (when it can't boot at all) - it would try to load "help.rom" from the USB.
    If the DVR loads into the user interface and then hangs - there is no simple way (IMHO) to update the firmware using "help.rom".

    There is another, more complicated way, though :) The DVR has RS-232 interface on board and it is possible to initiate the firmware update from there by issuing a couple of commands through a terminal during the boot.
    The RS-232 interface is situated next to the SATA connector. There are four pins: GND, Rx, Tx and one is unused.

    http://i.imgur.com/rfEkjaJ.jpg?1
    img src: http://i.imgur.com/rfEkjaJ.jpg?1

    Posts(22) | Reviews | Tip post

  • romantu Tuesday, October 22, 2013 11:14 AM Reply
    You were right! Your post saved my day. Finally, with your help I managed to get it back to working condition. As I already described in my previous posts, after one claimed "successful" Firmware update to 1.8.3 in the past, my DVR just kept rebooting again and again with a couple of beeps in between. Numerous attempts to restore the Firmware from help.rom via USB did not succeed. At the beginning I did not suspect the USB flash drive itself, as it was successfully used several times before - to update the Firmware of the very same DVR drive. After your post I just kept insisting, again and again. I tried around 10 different USB flash drives. I used the well known "HP USB Disk Storage Format Tool" to format the flash drives with FAT32. And suddenly it worked with the 10th flash drive! The help.rom was loaded and after a reboot, the DVR loaded and initialized successfully. Your information about the menu setting "KeyPad Type" was also of great importance. Originally I thought that I got the wrong firmware version, based on the displaced buttons on the front panel and based on my printed label on the back of the unit. After playing with this setting though, everything got back to normal again. Thanks a lot for your great help! I owe you a beer.
    P.S. I tried the telnet connection (to see what is it all about) but could not go beyond the password prompt. Tried all combinations like 123456 or 111111 etc. but could not guess the right one.
    Posts(3) | Reviews | Tip post

  • xxxQ2 Tuesday, November 12, 2013 2:25 PM Reply
    That's great! I'm glad you finally managed to unbrick it. I had exactly the same situation - it did not want to load the help.rom until the flash drive was formatted to FAT32 under Linux (unfortunately, I don't remember exact parameters that were used). Initially, I had no idea that the flash drive was the culprit, so I connected to the RS232 port with a terminal, and looked what's going on during the boot - it simply did not recognize the filesystem on the flash drive, and therefore could not read help.rom.

    Regarding telnet, they seem to have chosen a pretty good password. None of the basic passwords worked. If anyone knows the password, please share here.
    Posts(22) | Reviews | Tip post

    post edited by xxxQ2 on 11/12/2013 at 2:26 PM
  • liranbx Saturday, February 01, 2014 11:08 PM Reply
    For anybody who is still looking for telnet login,
    I found that on my JA7208S the login was, root and password is juantech.
    Hope it will help someone.
    Posts(1) | Reviews | Tip post

  • xxxQ2 Monday, February 03, 2014 4:32 AM Reply
    Wow, thanks for the password! Works for the JA7204 too.
    Posts(22) | Reviews | Tip post

  • refigerator Monday, October 27, 2014 1:15 AM Reply
    Hi romantu,
    i need a firmware vor my JA7204 which it have FTP. Did you have a Update?
    Posts(1) | Reviews | Tip post

  • ritchys Saturday, November 01, 2014 7:28 PM Reply
    Hello romantu,

    I'm trying to get the FWHI1504A_20130821_DVR_JA7204_1_8_3_7969B10.rom & FWHI1504S_20130821_DVR_JA7204S_1_8_3_7969B10
    to upgrade my firmware but I couldn't find them on the net neither on posted links above.

    Would you kindly provide me with these files?

    I have an issue with my GUI where there is no option in the network for the mobile port. I'm trying to connect to the DVR using an external connection but my attempts using the eseenet failed so far, I only succeeded by using a web browser by using ddns.

    Thanks in advance
    Posts(1) | Reviews | Tip post

  • tsvyak07 Sunday, September 27, 2015 2:09 PM Reply
    Hello my dear friends, i need a help i have this is model DVR JA7204 after the update for different and unknown to me reasons your drive is stuck in the welcoming screen "System initializing". What to do??
    Posts(1) | Reviews | Tip post

Page 2 of 2
Go to Page:
«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere