Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

TX pin on latest Arduino Mega is not working

  • tronicgr Wednesday, July 17, 2013 4:41 PM Reply
    Hi,

    Just want to know the reason the TX pin in the latest Arduino Mega boards (SKU: 118042) is not working anymore. I just received three of them and none of then wants to talk to arduino IDE. Programming them is impossible!

    Its not a problem from my side. I used more that 30 of these in projects the last 6 months and never had such a problem. I plugged in one of the older arduino boards I still had and was working fine so its not problem on my computer or the shields I use.

    I also did loop back test by placing a jumper on the RX-TX pins on the board and could not get any characters I was typing on back on the terminal unlike the older board that was doing loop-back perfectly.

    What is wrong with these new boards? I mean, they are useless to me if communications are not working. And I expect 6 more to arrive to me within a month and its too late to cancel the orders now as they were already shipped! It seems to me that a counterfeit FTDI chip was used or a bad batch of them!

    Waiting some answers please! Thanks!

    Thanos
    http://motionsim.blogspot.com/


    Posts(29) | Reviews | Tip post

  • tronicgr Wednesday, July 17, 2013 10:26 PM Reply
    I have just received two more sku.118042 arduino mega and they have exactly the same problem. I now have 5 of them with the exact same malfunction. I guess I'll have to wait for the 3 that are on their way to me to make a large package create a RMA (on multiple orders) and return them all... !!

    Should I make a video of the failed boards? The Arduino IDE denies to load program to them returning a message:
    "stk500_getsync(): not in sync: resp=0x00 error". And of course in my application I get no response back from the board for direct loop-back of the FTDI chip...

    Thanks
    Thanos
    http://motionsim.blogspot.com/
    Posts(29) | Reviews | Tip post

    post edited by tronicgr on 7/17/2013 at 10:27 PM
  • tronicgr Saturday, July 20, 2013 3:40 PM Reply
    Here is a video describing the problem. I verified that the problem is the FTDI FT232RL chip that is defective on all 5 boards I have in my hands so far.

    Video Link: http://youtu.be/_eqjMbpshzw

    I will place and RMA on the 5 boards I have now, and RMA the rest 3 that are on their way to me when I receive them I guess.

    Orders with the defective arduino mega boards:
    130612001059992642 (1 piece)
    130625001072361568 (1 piece)
    130625001076265068 (1 piece)
    130626001085757577 (2 pieces)

    Orders not yet delivered but I expect them to be same defective!
    130713001040894032 (1 piece)
    130713001043668368 (1 piece)


    Thanks
    Thanos
    http://motionsim.blogspot.com/
    Posts(29) | Reviews | Tip post

    post edited by tronicgr on 7/20/2013 at 4:05 PM
  • josgoumix Monday, July 22, 2013 1:27 AM Reply
    I just received my ATmega2560 and neither does work. It not communicate and the device manager it appears with error. However another same board is working Ok.

    I request RMA.

    Thanks.
    Posts(2) | Reviews | Tip post

  • onpsk Wednesday, July 31, 2013 5:59 PM Reply
    Similar symptoms here. Impossible to write program to the chip, error: "avrdude: stk500_getsync(): not in sync: resp=0x00"

    EDIT: Originally I tried it on Win7 Asus and I got 'not in sync' error. Now I tried it on my older WinXP HP and it worked.
    Posts(11) | Reviews | Tip post

    post edited by onpsk on 8/1/2013 at 1:56 PM
  • tronicgr Friday, August 02, 2013 8:28 AM Reply
    Using the obsolete now WindowsXP does not solve the problem. All my customers including me are using Windows7 and windows8...
    Posts(29) | Reviews | Tip post

  • josgoumix Friday, August 02, 2013 9:25 AM Reply
    I use Windows7 Hp but I have also used XP. I tested one equal board of my friend and it worked ok, but mine it didn't work, it also gave error driver. Then I decided to return the board and I ordered one RMA.

    Thank you for your interest.
    Posts(2) | Reviews | Tip post

  • tronicgr Saturday, August 03, 2013 9:38 PM Reply
    The FTDI chip that is used on the latest batch of these boards is just not good. Probably counterfeit. It appears correctly in the device driver as COM PORT, but it does not respond to serial data. This or they performed a horrible redesign flaw on the boards now. Tried for hours to trace the error but unfortunately most of the TX-RX trace lines are hidden under the chip itself.


    http://img571.imageshack.us/img571/4584/86b4.jpg
    img src:
    http://img571.imageshack.us/img571/4584/86b4.jpg



    Its sad because I bought more than 40 of these arduino mega boards here before and I never had problem with them. They were great quality! Until this problem is resolved I will hold on buying it for now.

    Thanos
    Posts(29) | Reviews | Tip post

    post edited by tronicgr on 8/3/2013 at 9:38 PM
  • GVillalon Tuesday, October 15, 2013 9:12 AM Reply
    Time ago I bought 3 of these and worked fine.

    Now I bought 21 o f them and all of them are defective. I can program them directly without bootloader using another Arduino as ISP, but no communication through the FTDI chip at all although the TX/RX leds blinks.
    Posts(1) | Reviews | Tip post

  • tronicgr Wednesday, October 16, 2013 8:55 AM Reply
    Good luck returning them... I had to return 10 of them and it was pain on the a$$.... :)
    Posts(29) | Reviews | Tip post

«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere