Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

Don't try to "save config" with u-center, fried!!

  • eatatjoes10 Friday, November 8, 2013 7:52 PM Reply
    I tried to use this nice thing with a BTtoTTL module sku.104299, to build a wireless (Bluetooth) GPS receiver, I had no success.
    The module worked very nice with a "RS232 Serial Port Converter" (sku.104325) at a baudrate of 38400 (default module setting), but I had no sucess to create a wireless serial connection to my pc with the BT module.
    After app. 10 hours of trying everything, I thought I'll give it a try to change the baudrate of the GPS module via u-center (the U-Blox software): worst idea I ever had! The u-center user guide says, it is possible to save the parameters to the non volatile memory of the module, but when pressing "send" something went wrong. The GPS module is fried now... It takes 0,7A and becomes too hot to touch in 2 seconds.

    If anybody needs to change the settings of this GPS-module: it might be fried!
    experienced toddler
    Posts(207) | Reviews | Tip post

  • ebpDoug Saturday, November 9, 2013 12:54 PM Reply
    While is not impossible that saving the config "broke" something, I think it is more likely to have been a strange coincidence. U-blox and u-center have been around for a long time. I would have to double check, but I think the version of U-center I use is at least a year of two old (still current version), and if using it to save config fried modules, I find it hard to believe that U-blox wouldn't have fixed it by now.
    There is a possibility that some of the NEO-6 I/O pins are tied to ground or supply in an inappropriate way on the module, and hence cause excessive current if programmed to the wrong level.

    The default baud rate for the NEO-6M is 9600 baud, not 38400, so if the board uses the latter, it must have be configured by the board manufacturer.

    The NEO-6M specification for supply voltage and input voltage is 3.6V absolute maximum. This means that according to spec's, using 5V levels for signals is prohibited. The module I have appears to be 5V-tolerant on the serial input, but that may be just dumb luck. The RS-232 to "TTL" converter you used almost certainly puts out 5V for "mark" on its TTL output. If the NEO-6M really shouldn't have input above 3.6V, there is a possibility that driving with 5V could have resulted in a sort of chain reaction that killed the module. The data sheet really isn't very clear when it comes to the input voltage spec. It says 3.6V abs max, but the module will run at as little as 2.7V, sort of implying tolerance of 0.9V above the supply, but it isn't clear.
    For low-speed signals like async serial at a few tens of kbps, you can USUALLY use a resistor in series in the data line to limit current and rely on protection diodes internal to the devices to clamp the voltage. Something in the 5K to 25K range would be suitable. If you make the resistance too high, capacitance at the input will distort the waveform.

    The voltage regulator on your board may have failed short-circuit. If you can identify the input and output pins you can easily check that with an ohmmeter. If it has, and you replace it, there is a tiny chance the NEO-6M will have survived.
    Posts(1003) | Reviews | Tip post

    post edited by ebpDoug on 11/9/2013 at 12:55 PM
  • eatatjoes10 Tuesday, November 12, 2013 11:46 AM Reply
    Hi ebpDoug,
    thank you very much for your thoughts.
    I know it sounds strange (if not impossible!), that the software could "fry" something. I also believe it's not a problem with U-center. But it was very strange, and I just wanted to share my experience.

    About the ttl/power voltage level issue, I thought about that too:
    all the datasheets can be found here http://m5.img.dxcdn.com/CDDriver/CD/sku.226460.rar
    the NEO-6M-0-001 GPS-chip on this board uses 3,3V ttl-level, that's true. Also, there is a RT9193-33 on this board, that makes it possible to power the module from 2,5-5,5V (tested, works great). But the ttl-level will allways stay at 3,3V (pins 20/21), because it comes from the NEO-6M-0-001, not from the board.
    The serial adapter sku.104325 I used to connect the board to the PC uses a MAX3232. It's ttl-level will be the same as the power level, and the rs232 level will be double (~6,6V). So, if I use 3,3V to feed both modules, everything should be fine... Believe me or not, it worked perfect like that for several hours.
    But to be honest: in my hours and hours of trying different parameters, and often switching between BT-module and serial adapter, two or three times I accidently powered the serial and the GPS-module with 5V (ttl-level at 5V!), but each time only for a few seconds. And the U-Blox tolerated that (the R2/3, 510 ohm??), no problem at all. But, I swear, this "5V level" was not the case, when my "BBQ" happened...

    You are also right with the baud rates: the U-Blox datasheet for the NEO-6M-0-001 says, the default baudrate is 9600. On this board the connections to the pins 14 and 15 (cfg-com0/1) are both connected to grd via a 1k resistor, this also indicates both are at "high", which means "baudrate 9600". But then, the Alientek "datasheet" for this module claims, the default rate is 38400. And when I connected it to the U-center (via the serial adapter) the software also told me it's 38400. So this should be true. But it doesn't really matter, I tried both (and every other possible rate) with the BT module, and none of them worked. The PC paired with the BT module, but the U-center refused to receive any data from the GPS. Because of that, I thought I should try to set the GPS module to 9600 baud... That story was told, BBQ.

    Anyway: I don't know, why it didn't work with the BT-module nor what toasted the NEO-6. I ordered a new GPS module, that then will be connected via USB (SKU.149589). But if anybody finds a way to use a BT-module with this sku, don't hesitate to write here. I'll still prefer that solution.
    experienced toddler
    Posts(207) | Reviews | Tip post

    post edited by eatatjoes10 on 11/12/2013 at 11:50 AM
  • ebpDoug Tuesday, November 12, 2013 1:01 PM Reply
    Were you powering your TTL to RS-232 converter via the USB jack? Since USB bus voltage is nominally 5V (which the MX3232 can handle), you would get approximately 5V "TTL" levels. Or is there a voltage regulator on the converter board?
    Still, what you experienced is hard to explain except possibly as a delayed failure. (I once had a failure in a part on a 1kW switch mode power supply I was developing. After fixing the problem, I powered the board up and it ran for a short time. I'll never know the exact sequence of events, but the end result was that a large electrolytic capacitor on the board "vented" rather suddenly - it sounded like someone fired a shotgun in my lab. I'm pretty sure it was a "delayed reaction" to over-stress caused by the previous problem. At least low-voltage stuff usually dies quietly, though I have seen a small voltage regulator IC emit light - briefly.)
    Anyway, I hope you get things to work the way you want. The u-blox modules are amazing.
    Any chance the problem with the Bluetooth link might have been a result of the u-blox module sending data before the BT module was ready for it? The u-blox module, if the factory default behavior hasn't been changed, is to send several NMEA "sentences" once a second starting almost as soon as the module has been powered up. You can see this if you use something like hyperterminal to communicate with the module. Could you get your BT module to do loop-back (connect TXD to RXD)?

    I posted some comments in the forum for SKU 207550 on how to fix messed up U-center workspace - it certainly isn't bug-free software.
    Posts(1003) | Reviews | Tip post

  • eatatjoes10 Tuesday, November 12, 2013 2:27 PM Reply
    No, I did not power it via the usb jack, because of the 5V ttl level, knew that problem.
    Also, both modules where first connected, then powered.

    I also thought about what you wrote about the voltage regulator (that it might have failed):
    as the board doesn't work anymore I can not really measure it, and it's a bit too small, to just desolder and test it. But I tried to power the board with 3V and limited current to 0.1A, the regulator then should still give the 3.3V. But there is no voltage between it's pin 5 and gnd (before, it was). If not powered, I measure a resistance of ~3 Ohms between the two pins, this seems wrong to me, and could explain the high amps at 5V. So you might be right, to say it could be a failure in the regulator! It also would explain, why the NEO-6 became hot, because iit doesn't like the full 5V...
    If I had one lying around I would try to replace it and test that. But I don't have one!
    Wait, I think, I'll just desolder it, and try to power the board directly with 3.3V. If the LED lights up...

    I didn't test the loop back for this BT module, but also tried another module, that I know to be working, also no success. As I wrote, I fiddled around for hours. I was allways able to receive data with the serial adapter, but not with the BT module. My idea was, it could be a problem with "timing" at high baudrates (like you wrote about the "sentences"), therefor I wanted to try the lower baudrate...

    I'm sure, if anybody can make this combination work, I will find a very simple explanation, why it didn't work for me. But maybe you're right, and this combination does not work, because of... something that is some kind of a very simple thing???
    Maybe it is as simple as "my WIN7 driver did pair with the BT module, but the serial connection didn't work the way it should". I also had problems with the other BT module, when I used it with WIN7 drivers, but I was allways able to make it work. With an older WINXP PC, that uses a cheapo BT dongle (from DX) and the very old bluesoleil software I never had those problems. I thought about trying the bluesoleil drivers on my WIN7 PC, but I read about problems with that solution too, e.g. it "kills" the WIN7 drivers and it is very hard to revert that. So I didn't want to test this, before I didn't try other things. I also tried to connect the BT-GPS combo with the older PC (bluesoleil), but also with no success.
    I tried the BT dongle with WIN7, WIN7 drivers in the WIN7 PC, guess what...
    no success.
    Hours and hours of learning (nothing)...
    Start sarcasm:
    I should better buy a BT-GPS module for >50 bucks, and be happy if it works. If not, I could revert it to the dealer.
    End sarcasm
    ;-)

    Btw.: I hope, all readers enjoy this loooooong thread without results. Have a nice day!
    experienced toddler
    Posts(207) | Reviews | Tip post

  • eatatjoes10 Tuesday, November 12, 2013 2:40 PM Reply
    Ok, tried to power it without the regulator, no success. The voltage applied to the VCC solder pad and gnd breaks down to 0.7V. Looks like the NEO-6 is shorted.
    experienced toddler
    Posts(207) | Reviews | Tip post

    post edited by eatatjoes10 on 11/12/2013 at 2:42 PM
  • ebpDoug Tuesday, November 12, 2013 4:00 PM Reply
    "Looks like the NEO-6 is shorted"
    Oh, krud!
    The p/n for the regulator didn't ring a bell so I fetched the data sheet. I remember getting quite interested in the Richtek regulators because of very low cost from one of my suppliers - then I noticed the 5.5V max input voltage. Again, oh krud. Useful, but not for most of what I design.

    Loopback with hyperterminal is always a useful test to do early on in troubleshooting serial things (hyperterminal doesn't do local "echo", so if you type something and get it displayed on the screen, you know both transmit and receive are working). Since you have two serial device available (BT & TTL-232) you could even test with two instances of hyperterminal on the same computer, each talking to the other. Simple loopback won't find problems with baud rates, since transmit and receive clocks come from the same source. Even if the source is grossly off, loopback will still work. That's where testing com's between two ports can help. An oscilloscope is very helpful, but not everyone has one.

    Baud rates that are "off" will usually still result in something being received - it will just be seemingly random characters. Again, hyperterminal is useful because it will simply display what it gets, whereas something like u-center might completely reject it due to error control code.

    I totally agree with the idea that the solution will likely be simple. I have repeatedly spent large amounts of time tracking down problems where the ultimate solutions were often very simple.

    I guess there isn't much to do now but wait til your new module arrives.
    Posts(1003) | Reviews | Tip post

  • eatatjoes10 Tuesday, November 12, 2013 5:19 PM Reply
    Yep, I'll have to wait now. But it's allready on it's way. Not at the airport yet, b ut on it's way. Last time, i saw it comes from somewhere northeast in China, but it was pretty fast, only three weeks.
    Damn thing, I have to wait for three weeks now... ;-)

    The suggestion with the loop back is great, didn't think of that, to test my modules. I'll keep that in mind next time.

    I've read something about the BT module, don't remember where, a guy used it for his arduino I think, and he had to modify his software, because he had problems with the "timing". The BT module was a bit too slow, to transmit the complete data (some milliseconds), allways lost the beginning. So he had to program a delay to his software, and succeeded. Maybe it's the same here.

    Oh, btw.: I could not test the regulator itself, it chipped when I desoldered it. But anyway, even if the U-blox should still work, what do I need two of them for?? ;-)

    But, thank you for the good response and ideas, will keep them in mind for the next time!
    experienced toddler
    Posts(207) | Reviews | Tip post

    post edited by eatatjoes10 on 11/12/2013 at 5:22 PM
  • eatatjoes10 Thursday, November 21, 2013 1:56 PM Reply
    DX is the best, only 13 days this time. This was my fastest delivery to germany.

    Now the GPS module is connected to sku.149589 (it's voltage jumper is set to the "3,3V" side), WIN7 found the driver for sku.149589. Wires connect Vcc to Vdd, Gnd to Gnd, RXD to TXD, Txd to RXD.

    It works right away. Good thing.
    experienced toddler
    Posts(207) | Reviews | Tip post

    post edited by eatatjoes10 on 11/21/2013 at 1:57 PM
  • AlCristobal Wednesday, November 27, 2013 1:43 PM Reply
    Dear eatatjoes10,

    I am trying to change the settings in one of this modules, I have try the miniGPS program and the U-Center, but I have not luck.
    Could you please explain me how to change the baud rate from 38400 to 4800 and leave just the RMC string?

    Thanks a lot

    ALBERTO
    Posts(4) | Reviews | Tip post

«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere