Wish
DX  » Community » Forums
«See all threads (in Arduino Enthusiasts)
Arduino Enthusiasts

GY-85 IMU Board - no data from ADXL345 accel

  • DiegoHenrix Monday, January 6, 2014 8:01 AM Reply
    The ADXL345 ship on the GY-85 board do not response the Arduino UNO board that i used for testing. However the other chips (ITG3205 and HMC5883L) work normaly. All the data i get from ADXL345 are zeros while i get expected data from other ICs on the board. I cant get even the DEVICE_ID from the ADXL reading the 0x00 adress. I tryed many codes developed for Arduino to read these sensor but behavior is the same, zeros from ADXL. So, is it a faulty ADXL345 IC or am i doing something wrong?

    Some codes and conections that i used:

    http://theccontinuum.wordpress.com/2012/09/24/arduino-imu-pitch-roll-from-accelerometer/ (designed for gy-80 but should work with gy-85 since the accel is the same, as the basic connections)

    http://www.rcgroups.com/forums/showthread.php?t=1677559 (DIY Headtracker - Dennis Frie)


    It took some time to figure out because i was waitting for the Arduino to test the GY-85 board. If its a faulty part can i ask a replacement from DX even some days later?
    Posts(1) | Reviews | Tip post

    post edited by DiegoHenrix on 1/7/2014 at 9:26 AM
«Reply to this thread (in Arduino Enthusiasts)
Arduino Enthusiasts

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere