Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

My experience after 1 month of use

  • wolfik Saturday, August 25, 2007 8:22 AM Reply
    is, that the charger stopped working.. This morning (about 20 days since I purchased it) I plugged it in and heard some sparks inside, thats it. Dead. :( Too bad I ordered 2 more. Wish these things lasted longer even for a higher price.
    Posts(61) | Reviews | Tip post

  • Freddie Tuesday, October 2, 2007 7:59 AM Reply
    Exactly the same thing has happened to me twice so far. The chargers completely malfunction then spark and go dead. I am still trying to work out what happened. I will have to buy a third or a different charger.
    Posts(7) | Reviews | Tip post

  • laser123 Saturday, December 22, 2007 10:52 PM Reply
    Do any or both of you live in a place where the ac outlets put out 220v ac, maybe that is the problem.
    Posts(249) | Reviews | Tip post

  • ahpua Sunday, March 2, 2008 8:40 PM Reply
    Hi laser123,

    Mine also gone burst after 30 minutes charged... :( I guess this is due to 220v ac problem? Any recommendation which charges (sku) support 220v ac? Thanks.
    Posts(9) | Reviews | Tip post

  • laser123 Saturday, April 5, 2008 11:59 PM Reply
    Well that makes me feel better, hopefully mine wont break since i have 120v ac outlets.

    But thats bad for people with 220v outlets though, i think you can get a converter for around 10 dollars that will change it into 120v ac, that might work.
    Posts(249) | Reviews | Tip post

  • JimHodge Monday, September 22, 2008 9:01 AM Reply
    Mine lasted 20 minutes and kaboom, took out the line circuit breaker. I'm thinking it's a voltage thing too, 240V here.
    Using another 5V adapter into it now and it seems to be working fine, just lost the power supply.
    Posts(11) | Reviews | Tip post

  • angusW Thursday, December 18, 2008 2:59 PM Reply
    I've had mine for about 5 months and so far so good. 110vac here.

    Funny as it says "AC:110V-240V" on the back of the charger and wall wart.
    Posts(83) | Reviews | Tip post

  • quarx Tuesday, December 23, 2008 4:36 PM Reply
    mine is not charging up to 4.2V as before. Now it peaks at 3.9V to 4V. I can conclude it is the charger, since I have charged several kinds of batteries on it with consistent 3.9-4V final voltage.
    Posts(123) | Reviews | Tip post

  • alaskanalain Tuesday, October 20, 2009 3:10 AM Reply
    Mine seems to have done that too after only about three charges, I use 110v
    Posts(8) | Reviews | Tip post

  • GavUK2 Monday, February 8, 2010 5:58 PM Reply
    Mine burnt out on 2nd use. These are obviously utter s***e!
    Posts(86) | Reviews | Tip post

Page 1 of 2
Go to Page:
«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere