Wish
DX  » Community » Forums
«See all threads (in Product Forum)
Product Forum

DOESN'T WORK

  • CeBin Wednesday, October 15, 2008 10:26 PM Reply
    I just received the item today,
    charged for long time, was trying to use it...
    when i press the button on top nothing shows...no light nothing... and when i plug it on my computer... it doesn't even detect.... what the heck??? what do i do???
    Posts(5) | Reviews | Tip post

  • 54321 Wednesday, October 15, 2008 10:30 PM Reply

    Posts(3150) | Reviews | Tip post

  • CeBin Wednesday, October 15, 2008 10:32 PM Reply
    After reading some posts... i tried resetting and it works fine... but THANKS!!!!
    Posts(5) | Reviews | Tip post

  • 54321 Wednesday, October 15, 2008 10:35 PM Reply
    Hmmmmmmmmmm.........

    Posts(3150) | Reviews | Tip post

  • TomySakazaki Wednesday, October 15, 2008 11:32 PM Reply
    I think that would be nice to post the link used to get the item working =D You never know when someone will get this thread and not the one telling the solution.
    Posts(16) | Reviews | Tip post

  • Mike-H Thursday, October 16, 2008 3:14 AM Reply
    resetting is nothing harder than sticking a pin in the reset hole on the back of the pen (the lower hole), thats it.

    oh and remember these pens dont seem to charge from the mains charger, only from the usb.



    Posts(4615) | Reviews | Tip post

  • andrade4 Thursday, October 16, 2008 3:17 AM Reply
    CeBin,
    I think you should also edit the title of this thread to reflect that the issue is fixed.
    ===========
    http://www.youtube.com/user/dx4lover
    ^Lots of DX reviews
    Vancouver,Canada
    Posts(4043) | Reviews | Tip post

  • sp-bremen Wednesday, December 17, 2008 3:36 PM Reply

    reset does not help at all, for me has not helped

    after unpacking, I tested the pen briefly,
    everything worked.
    I put the pen in my usb port and looked at the videos,
    He was recognized as a drive, everything was good
    I thought I let the pen to load off
    after about 10 hours, the battery is still not fully, I did and I thought why? I decided to use the included charger, I noticed the LED does not light?? I removed the pen immediately and tried it again on pc.
    The pen is now dead, he is not recognized by pc, and will no longer be loaded. also a reset did not try to fix the problem.
    the pen shows no more responsive, not receptive no blinking LED, nothing.
    I think that is realy dead. But why??
    Posts(3) | Reviews | Tip post

«Reply to this thread (in Product Forum)
Product Forum

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere