Wish
DX  » Community » Forums

«To post a new topic, please pick one of the categories from the left.

Topics Views Replies Last Post
Items not received, no response to ticket
General Discussions started by: polesapart on 2/17/2014
197 1 2/17/2014
by cyclist
Is this really HiSpeed (480 Mbps)?
Product Forum started by: polesapart on 6/9/2013
327 1 6/22/2013
by polesapart
Does it come with the ballasts or not?
Product Forum started by: polesapart on 10/23/2012
200 1 10/23/2012
by desolder
LM2577 is rated to max. output of 15V
Product Forum started by: polesapart on 10/23/2012
356 2 10/24/2012
by MikeAusD
I bought the model MB860 and received the ME860. [last]
Product Forum started by: SandinoSousa on 4/20/2012
1748 12 11/25/2012
by andreluizxxx
Is it really Zirconia?
Product Forum started by: polesapart on 5/11/2012
295 2 5/11/2012
by desolder
Nice
Product Forum started by: Francoo on 4/16/2012
1449 2 5/11/2012
by polesapart
Playing while connected to the power supply
Product Forum started by: dagsman on 2/2/2012
206 2 2/2/2012
by polesapart
RAM size
Product Forum started by: polesapart on 10/18/2011
379 1 2/26/2012
by JamiroCB
Is this kit complete?
Product Forum started by: polesapart on 10/13/2011
934 2 10/24/2011
by daphilipp
write speed
Product Forum started by: sirber on 10/6/2011
1462 8 8/23/2012
by saraos
charge while listening music?
Product Forum started by: xavif on 9/14/2011
1029 8 1/7/2012
by PablodePilar
Ambiguous description - DX please update
Product Forum started by: carvalhais on 8/2/2011
562 1 8/3/2011
by polesapart
A9?
Product Forum started by: DeDmorozzzz on 5/28/2011
1336 3 7/4/2011
by cloudptt
@dx @staff does the manufacturer has firmware?
Product Forum started by: liork12 on 10/2/2010
832 3 5/4/2011
by polesapart
AV In - Alguem já conseguiu colocar pra funcionar?
Product Forum started by: BigTam on 1/4/2011
1290 4 3/26/2012
by ganhebonus
is it available now?
Product Forum started by: Willol on 3/11/2011
646 3 7/22/2011
by asalto
Why more expensive than sku.25948?
Product Forum started by: polesapart on 4/12/2011
477 2 4/13/2011
by narspt
Not an USB 2.0 hub. Very Dissapointed...
Product Forum started by: ChacalGO on 9/17/2010
494 4 4/12/2011
by polesapart
Late and slow?
Product Forum started by: PeterLam on 3/30/2011
3226 7 7/5/2011
by mmatoo
Page 1 of 5
Go to Page:

«To post a new topic, please pick one of the categories from the left.

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere