Wish
DX  » Community » Forums
«See all threads (in Computer)
Computer

Jesurun Mini PC not working correclty

  • Mad_Maxx Tuesday, September 24, 2013 3:55 PM Reply
    hello
    so, I finally got my mini android pc after 2 months, it's this one http://dx.com/p/jesurun-nx003ii-quad-core-android-4-1-mini-pc-google-tv-player-w-2gb-ram-8gb-rom-xbmc-netflix-217147

    it's not exactly as shown, different antenna and AC adapter, silver not gray, transparent "mini adroid pc" box
    has android 4.2.2

    ASAP I plugged it it it literally blew up! flash and burned smell out of the AC adapter, it's not working anymore..
    hoping the mini pc was fine, I connected the mini tv to my TV via the usb port and it lit up, boots and reboots, without coming to the desktop, even tried another AC adapter I have, still the same, no desktop.

    After trying to reset it (via the reset pin hole and menu) it finally worked, desktop came up after 3 tries and I started using it.
    It worked fine for 5 minutes then it rebooted on his own, it came to the desktop but wifi wouldn't go on.
    I rebooted (hard reboot, removing the usb) and wifi worked again, after 20 minutes it reboots (was just using google)
    It keeps rebooting after 5-10 minutes even by not doing anything, I cannot use the browser or youtube that it reboots

    not sure if it blew up too with the plug or not, it's not working fine
    any solutions? like firmware upgrade or else? I upgraded every app but it's the same

    opened a RMA

    thanks
    Max
    Posts(55) | Reviews | Tip post

    post edited by Mad_Maxx on 9/24/2013 at 3:58 PM
«Reply to this thread (in Computer)
Computer

Reply

Subject:

* 50 characters max

Message:

Please note: HTML codes are not allowed anywhere on this page (otherwise you will see an error).

Please note that DealExtreme Forums are not a sales or product support board. While we do constantly participate in this forum, please contact us via support ticket for a guaranteed fast response. We make every effort to make the quickest replies.

DX Everywhere